• collective.amberjack discussion

  • ConfigurationExecutionError with version trunk collective.amberjack products

    from macagua on Jun 08, 2011 04:06 PM
    Hi guys 
    
    I have been working with this project, offers Spanish translation for collective.amberjack products initially for plone 3.3.5, now I am testing this products on Plone 4.0.5, for that I am using a version of Buildout configuration file (0) based on original file (1) and when re-buildout and started my instance zope show me a error like this (2)
    
    Any idea how resulte this?
    
    I hope to hear about your comments comming soon
    
    (0) http://pastebin.com/RZTxyh1Y 
    (1) https://svn.plone.org/svn/collective/collective.amberjack.buildout/trunk/buildout.cfg
    (2) http://pastebin.com/44ebx8Rh 
    Thread Outline:
  • Re: ConfigurationExecutionError with version trunk collective.amberjack products

    from macagua on Jun 14, 2011 01:19 PM
    Already solved this problem by running the following command:
    
    ./bin/buildout -vn
    
    and later re-buildout 
    
    ./bin/buildout -vnc amberjack.cfg
    
    On 08/06/2011 20:06, Leonardo J. Caballero G. wrote:
    > Hi guys 
    > 
    > I have been working with this project, offers Spanish translation for
    > collective.amberjack products initially for plone 3.3.5, now I am testing
    > this products on Plone 4.0.5, for that I am using a version of Buildout
    > configuration file (0) based on original file (1) and when re-buildout and
    > started my instance zope show me a error like this (2) 
    > Any idea how resulte this?
    > 
    > I hope to hear about your comments comming soon
    > 
    > (0) http://pastebin.com/RZTxyh1Y 
    > (1)
    >
    > https://svn.plone.org/svn/collective/collective.amberjack.buildout/trunk/buildout.cfg
    > (2) http://pastebin.com/44ebx8Rh 
    
  • Re: ConfigurationExecutionError with version trunk collective.amberjack products

    from mirco_angelini on Jun 14, 2011 06:19 PM
    Hi Leonardo,
    
    thanks for your report.
    
    I've included the following line in configure.zcml into
    collective.amberjack.portlet package:
      <include package="plone.app.portlets" />
    
    If collective.amberjack.portlet's ZCML is loaded before plone.app.portlets,
    then the permission may not have been registered yet.
    
    I've fixed the problem into the trunk of collective.amberjack.portlet
    
    
    • Re: ConfigurationExecutionError with version trunk collective.amberjack products

      from macagua on Oct 03, 2011 11:48 AM
      On Jun 14, 2011 10:19 PM, Mirco Angelini wrote:
      > Hi Leonardo,
      > 
      > thanks for your report.
      > 
      > I've included the following line in configure.zcml into
      > collective.amberjack.portlet package:
      >   <include package="plone.app.portlets" />
      > 
      > If collective.amberjack.portlet's ZCML is loaded before plone.app.portlets,
      > then the permission may not have been registered yet.
      > 
      > I've fixed the problem into the trunk of collective.amberjack.portlet
      > 
      
      Thanks you Mirco :D