• installing on lucid

last modified April 7 by egj

See also installing on even newer ubuntus

Python 2.4 is still required for OpenCore, but lucid doesn't provide py2.4 packages.

sudo apt-get install python-software-properties

sudo add-apt-repository ppa:fkrull/deadsnakes

sudo apt-get update && sudo apt-get install python2.4 python2.4-dev

You'll want to install virtualenv; I recommend downloading the standalone virtualenv.py script (https://raw.github.com/pypa/virtualenv/develop/virtualenv.py), placing it into /usr/local/bin/ and running virtualenv --python=python2.4 to create your opencore virtualenvs.

With that done, you can install the rest of the needed packages through apt-get:

build-essential libmysqlclient-dev mysql-server subversion wget apache2 libxml2-dev libxslt1-dev libsqlite3-dev php5 php5-mysql php5-cli libjpeg62-dev ­
And then­ you can proceed with the getting started instructions for building a site.